Fundraising complete, next renewal is August 2022. Paypal Donation Links US dollars CDN Dollars

Firefox hating on goolge properties

For general computer discussion & help, come here

Moderators: EvilHomer3k, Bakhtosh

Post Reply
User avatar
LordMortis
Posts: 66242
Joined: Tue Oct 12, 2004 11:26 pm

Firefox hating on goolge properties

Post by LordMortis »

I'm getting this frequently from multiple machines, multiple ISPs, multiple DNS. Google stuff just freaks out and stop loading. Two things ward off the problem.

1) opening the window again in a private window
2) removing the s from https

3) using a different browser...

This has been going on for like two weeks. As many other things as I dislike about FF, I'm loathe to use the major competitors Chrome/Edge. This could change the game if I don't get an easy fix soon.

Anyone else get this? It can't just be me when it's across multiple everything... Though now that I think about it, GMail does happen across all devices... hrrmmm... Maybe a cache cleanse and no more gmail aka google trackers might fix it...
User avatar
gilraen
Posts: 3394
Joined: Wed Sep 04, 2013 7:45 pm
Location: Broomfield, CO

Re: Firefox hating on goolge properties

Post by gilraen »

I work on a web-based application that hates aggressive browser caching. I have caching disabled in Firefox entirely to eliminate an extra layer of frustration when troubleshooting issues. So you can try it - I don't know how well it actually works now, they keep changing it between browser versions. It used to be an option in the Settings menu, now you go to the URL box, enter about:config, search for use-cache and toggle it to false.
User avatar
Anonymous Bosch
Posts: 9547
Joined: Thu Oct 14, 2004 6:09 pm
Location: Northern California [originally from the UK]

Re: Firefox hating on goolge properties

Post by Anonymous Bosch »

LordMortis wrote: Fri Nov 12, 2021 3:58 pm I'm getting this frequently from multiple machines, multiple ISPs, multiple DNS. Google stuff just freaks out and stop loading. Two things ward off the problem.

1) opening the window again in a private window
2) removing the s from https

3) using a different browser...

This has been going on for like two weeks. As many other things as I dislike about FF, I'm loathe to use the major competitors Chrome/Edge. This could change the game if I don't get an easy fix soon.

Anyone else get this? It can't just be me when it's across multiple everything... Though now that I think about it, GMail does happen across all devices... hrrmmm... Maybe a cache cleanse and no more gmail aka google trackers might fix it...
Personally, I prefer to deGoogle as much as possible.

But the suggestions provided in this Reddit thread may help with the difficulty you describe.
"Good intentions will always be pleaded for every assumption of authority. It is hardly too strong to say that the Constitution was made to guard the people against the dangers of good intentions. There are men in all ages who mean to govern well, but they mean to govern. They promise to be good masters, but they mean to be masters." -- Daniel Webster
User avatar
Jaymann
Posts: 14657
Joined: Mon Oct 25, 2004 7:13 pm
Location: California

Re: Firefox hating on goolge properties

Post by Jaymann »

This is exactly why I resist every effort of Big Google to have me link my devices, much less use my phone to access my bank account (JFC!). Likewise with Microsoft trying to force me to use Edge every time I boot up. As far as I am concerned, convenience = death.
Jaymann
]==(:::::::::::::>
Black Lives Matter
User avatar
LordMortis
Posts: 66242
Joined: Tue Oct 12, 2004 11:26 pm

Re: Firefox hating on goolge properties

Post by LordMortis »

use-cache setting didn't exist but it added when I typed it.

I'll see if that helps. Thanx

I'm afraid of the reddit thread bacause I don't understand what it is doing. I don't want to gimp the security of the browser to get google stuff to work better. Especially because google wants to spy on me as much as it possibly can.

https://www.reddit.com/r/firefox/commen ... except_in/

This describe me exactly
Last edited by LordMortis on Fri Nov 12, 2021 4:53 pm, edited 2 times in total.
User avatar
hitbyambulance
Posts: 8850
Joined: Wed Oct 13, 2004 3:51 am
Location: Map Ref 47.6°N 122.35°W
Contact:

Re: Firefox hating on goolge properties

Post by hitbyambulance »

i'm using FF and i do not have this issue, so it's something on your end.

first thing to always try is clear cache on page reload (or 'hard reload')

Hold down Ctrl, Shift and the 'R' key
or
Hold down Ctrl and press F5
User avatar
LordMortis
Posts: 66242
Joined: Tue Oct 12, 2004 11:26 pm

Re: Firefox hating on goolge properties

Post by LordMortis »

Clearing cookies that manage data seem to work on this workstation. I'll have to hit the others.... after making sure google doesn't have me auto logged in.
User avatar
Anonymous Bosch
Posts: 9547
Joined: Thu Oct 14, 2004 6:09 pm
Location: Northern California [originally from the UK]

Re: Firefox hating on goolge properties

Post by Anonymous Bosch »

LordMortis wrote: Fri Nov 12, 2021 4:41 pm use-cache setting didn't exist but it added when I typed it.

I'll see if that helps. Thanx

I'm afraid of the reddit thread bacause I don't understand what it is doing. I don't want to gimp the security of the browser to get google stuff to work better. Especially because google wants to spy on me as much as it possibly can.
FWIW, the first suggestion in the Reddit thread I linked to, of disabling 0-RTT, enhances your Firefox security and privacy, as explained in this Firefox Hardening guide:
wevpn.com wrote:Disable 0-RTT
Zero Round Trip Time Resumption (0-RTT) is a feature that is new in TLS 1.3 that allows a client and server to negotiate a connection with fewer steps, allowing https websites to load more quickly. There are two problems with this. First, in order to do this you lose forward secrecy (generating a new key for every session and throwing away the key when the session is over). Secondly, 0-RTT requires special implementation in order to prevent replay attacks, which some web developers will certainly fail to protect from. Disabling 0-RTT enhances security and privacy.

To Disable 0-RTT: Type security.tls.enable_0rtt_data into the search bar, and double click on the setting to set the feature to false. This will force full secure negotiation for all connections made by Firefox.
And the latter suggestion equates to flushing the cookies and site data of the problematic site(s).
"Good intentions will always be pleaded for every assumption of authority. It is hardly too strong to say that the Constitution was made to guard the people against the dangers of good intentions. There are men in all ages who mean to govern well, but they mean to govern. They promise to be good masters, but they mean to be masters." -- Daniel Webster
User avatar
LordMortis
Posts: 66242
Joined: Tue Oct 12, 2004 11:26 pm

Re: Firefox hating on goolge properties

Post by LordMortis »

Dammit. Nope not fixed. It really does seem to be a caching problem directly related to google. Going to go back and redo things. Also I'm going to see about updating my ad blocker.
Post Reply